1. This forum is read-only and considered to be an Archive. Please utilize the SmarterTools Community for future interaction and posts.

Smartermail 601 Error Failed all attempts to connect to the recipients mail server

Discussion in 'SmarterMail' started by Lan-Lord, Jun 2, 2008.

  1. mbecker

    mbecker New Member

    Hi all,

    I resolved my issues by getting our RDNS corrected with our ISP. I suggest everyone make sure they have theirs set correctly also.
  2. jeferaupp

    jeferaupp New Member


    I have the same problem but I have in my structure is 2 email server's only to receive and 1 server to be send email. To these 2 email server's I don't have the RDNS configured because these server's don't send emails and the sender server have configured the RDNS.

    The queston is: Do I need configure the RDNS to 2 email server's too or only to send server? Why?
  3. nathacof

    nathacof New Member

    Where did the 6yz type error message come from?


    The SMTP RFC lists no such reply code...
  4. hellosansks

    hellosansks New Member

    configure SmarterMail to use an outbound gateway login as system admin
    and go to Settings| Routing| Gateway servers then select New and enter
    in the server address and any authentication that is required by
    your E-mail Server provider (Eg : GoDaddy). Once this is done SmarterMail will send all emails through
    the gateway and the message will go out.
  5. joe velez

    joe velez New Member

    I am running 2 mail servers behind my firewall. Everything is fine for 1 mail server, but the SmarterMail server can only send. Nothing is coming. Also, it can only send to domains outside of my network, so if there is an email address on my other mail server the message is not getting through.

    Any suggestions?

    I am using 1-to-1 NAT
  6. Billy

    Billy New Member

    I hae the same situation as Joe with 2 mail servers behind a firewall on the same local network. I cant get SmarterMail to send to the other mail server.

    I have already manually changed the host files and this helped Exchange send to SmarterMail but did not help the other way. I was able to get it working with a private IP set as a second MX record but that was only a temporary solution because there are mail servers that block messages form domains that have private IP MX record.

    Any ideas.
  7. joe velez

    joe velez New Member

    i ended up just editing the hosts file on both mail servers to use the internal IPs for each mail server

    try that out and see if it works for you.
  8. bnichols

    bnichols New Member

    I just resolved a number of bizarre problems with SmarterMail's outgoing mail service by deleting both primary & secondary DNS IPs ("Settings > General Settings > Server Info" under the Admin account) to let SmarterMail resolve them itself (James Lance made the suggestion in this thread: http://www.smartertools.com/forums/p/14800/35210.aspx ). This was after trying every other remedy mentioned in these forums.

    From the logs it appears performance gradually degraded with an increasing number of errors until yesterday when outgoing mail service failed altogether with constant 601 errors. "unable to bind to local IP" errors, etc. In the case of the 601 errors, SM would try to use the same (wrong) IP in every case, no matter what the recipient's actual address.
  9. bijopgeorge

    bijopgeorge New Member

    601 error

    I have the same issue..I tried telnet as ur advice but i cant connect to 25 port of that server..pls advice me to fix this issue

    Thanking You

  10. DXD

    DXD Product Expert

    What server are you trying to connect to? Are you the admin of your mail server? Do you have a firewall blocking port 25? Are you using a Business grade inetenet connection. Most Home ISP block port 25.
  11. chicagonettech

    chicagonettech Product Expert

    Can you at least post the domain you are attempting to send to? we can run external tests and post the results.

    Many times the intended recipient has DNS or connectivity issues which cause the problems.
  12. Deektribe

    Deektribe New Member

    Same issue here...


    -----Original Message-----
    From: System Administrator [mailto:System Administrator]
    Sent: Thursday, September 13, 2012 3:29 PM
    To: *********@baumannassociates.com
    Subject: Delivery Failure

    Could not deliver message to the following recipient(s):

    Failed Recipient: *****@oysterdev.com
    Reason: Remote host said: 601 Attempted to send the message to the

    -- The header and top 20 lines of the message follows --

    Received: from comp2 (adsl-67-122-209-98.dsl.snfc21.pacbell.net
    []) by mail2.cnets.net with SMTP;
    Thu, 13 Sep 2012 11:25:12 -0700

    But my DNS is all good I am sure??

    Please help ST!
  13. chicagonettech

    chicagonettech Product Expert

  14. Deektribe

    Deektribe New Member

    I did...or was that for someone else?

    From: @baumannassociates.com
    To: @oysterdev.com

    btw and fyi, I saw none of these types of error till 10.3...but my time on 10.2 was limited and we just started migrating domains so usage has picked up since 10.2
  15. chicagonettech

    chicagonettech Product Expert

    Your MX server for BAUMAN ASSOCIATES reports as follows:

    Your MX records that were reported by your nameservers are:

    5 mail2.cnets.net

    With an rDNS of -> mail.youngdahl.net -> mail2.cnets.net

    Since the DOMAIN NAME for baumanassociates.com does not match any of the reported items, and, in fact, has no MX record, there appear to be DNS issues which are contributing to your FAILED ATTEMPTS to connect.
  16. Deektribe

    Deektribe New Member

    MXtoolbox reports everything is fine? I have always wondered about how to setup DNS for a mail server which handles multiple domains...the mail server won't respond with anything but it's FQDN...or however you tell it to responde...so what if the client wants to use mail.hisdomain.com when the FQDN is mail.mydomain.com?? If anyone can explain, please do!

    The MX record for baumannassociates.com points to mail2.cnets.net right now, so the reverse should be accurate, right?
  17. chicagonettech

    chicagonettech Product Expert

    You can do it one of two ways:

    1. Setup each domain with a SEPARATE IP ADDRESS and HOST RECORD in SmarterMail.

    2. Setup your server as the PRIMARY sending and receiving server, but setup SEPARATE MX RECORDS AND DNS for EACH DOMAIN. This requires only ONE IP ADDRESS and ONE rDNS, but you should also setup REVERSE DNS and PTR records for each domain - even though they all point back to a single domain and IP address.

    This is where advanced working knowledge of e-mail servers and services comes into play. It is also where SmarterMail, beginning with SmarterMail version 9, and the new IP ADDRESS and HOST mapping configuration makes life a lot easier.

    There are advantages and disadvantages to both methods.

    Example, one large real estate group, with close to 3,400 agents, receives so much spam, almost one million incoming spam messages per month, that it was actually beneficial to place them onto their own IP ADDRESS for blocking purposes.

    The use of a segregated IP ADDRESS for a specific domain was a helpful in isolating the OUTBOUND SPAM COMPLAINTS because about 50% of the agents have their own private "lists" to which they send every Monday morning and AOhelL and Yahoo were blocking legitimate messages from other domains who were originally sharing an IP address with them. Now they have their own IP ADDRESS and their domain name and IP ADDRESS are 100% responsible for all in and out bound traffic on that IP address because the majority of the "list" traffic is addresses used by agents in their weekly trashing of people's mail boxes were collected from people and online sources by the agents and not legitimate, double-opt-in addresses as required under the Canned Spam Act of 2009.

    Using a single IP ADDRESS for a group of small domains also means you can share resources like SSL certificates and send and receive all traffic under TLS when you are running SmarterMail Professional.
  18. Deektribe

    Deektribe New Member

    Excellent info, however, I have over 200 domains (I have only migrated a few to SM so far)...So just mail would eat almost a whole class C. Growth is steady, so it won't be too long before that class C runs out! Is there any other way for it to work correctly with just one IP? I am running SM Enterprise 10.3.

    The way it setup right now, the mail server has one IP, each domain has its own MX record pointing to mailserver.cnets.net, clients are fine with not having mail.theirdomain.com.

    Could I leave the MX record as is and create a A record or a CName to point mail.thierdomain.com to mailserver.cnets.net (or its IP)?

    Thanks in advance!

    EDIT: Sorry, I missed the #2 option on my first read, so if I use the #2 option will rdns report back all 200 domains? Is that ok? Right now it seems to give all dns entries for an IP in RDNS...
  19. chicagonettech

    chicagonettech Product Expert

    CNAMEs are PROHIBITED when naming MX hosts.

    Sent from my PC36100 using Tapatalk 2
  20. mishrag

    mishrag New Member


    I am also facing the same issue. My SmarterMail Server Configure with Nating and we have set the reverse DNS also as per required (Local IP with reverse DNS) in Biniding Option.
    Still our only one customer is facing this issue.
    Kindly suggestion require.