Smartermail 601 Error Failed all attempts to connect to the recipients mail server

Discussion in 'SmarterMail' started by Lan-Lord, Jun 2, 2008.

  1. Lan-Lord

    Lan-Lord New Member

    Hello. I am setting up smartermail, and I dont think that I have something set up propertly. Email is received by some domains, but not by others. I get a delivery failure bounce message (below) for the domains that dont recieve the email.

    Could not deliver message to the following recipient(s):

    Failed Recipient:
    Reason: Remote host said: 601 Failed all attempts to connect to the recipients mail server.
    Attempted to send the message to the following ip's:
    1.2.3.4

    Does anyone have some suggestions for resolving this situation? I dont know a lot about mail, but my gut feeling is that the destination email host is denying delivery for some reason.

    Thanks in advance.
  2. ST-JLance

    ST-JLance New Member

    In that particular case SmarterMail was able to get DNS information for the domain, but was unable to connect to the IP on port 25. You can check this by opening a command prompt on your server, and typing "telnet 1.2.3.4 25" where 1.2.3.4 is the actual ip listed in the bounce.
  3. somsen99

    somsen99 New Member

    So is this something that needs to be adjusted with SmarterMail or is this something that is on the recipients end of it? I had the same issue and am struggling to find an answer for this on how to fix the problem.
    Does anybody else have any ideas on how to alleviate the problem?
  4. Lan-Lord

    Lan-Lord New Member

    I think I resolved this problem by making sure my reverse dns was setup and by setting up an spf record on the dns. My understanding is that some of the destination email domains do some cross checks (via reverse dns and spf) to validate that you are legit.

    Good luck, it is definitely frustrating.
  5. somsen99

    somsen99 New Member

    Ha. Yes frustrating is an understatement. I'm a programmer who just got volunteered to be an IT guy trying to figure this and a few other issues out!
    I actually have SPF and Reverse DNS already checked in SmarterMail for "Enable for Filtering" so I'm pretty stumped. Do I need to check the "Enable for Incoming SMTP Blocking" and "Enable for Outgoing SMTP Blocking" boxes as well or will those make it worse? And would the weight have an affect on that too? I'm just using the defaults for that.
    Thanks for the feedback.
  6. michaelmuller

    michaelmuller Member

    I'm having the same problem. Two domains in one day suddenly bouncing. I've had several months of smooth sailing, a product of months of frustrating SPF, PTR, rDNS, etc., configuration and hours on the phone w/ ST support staff... and now it's cropping up again.
    > 601 Failed all attempts to connect to the recipients mail server.

    Any advice?
    Yahoo.com was the worst, followed up by Comcast.
  7. simonpinkney

    simonpinkney New Member

    I have had the following error

    Could not deliver message to the following recipient(s):

    Failed Recipient:
    Reason: Remote host said: 601 Attempted to send the message to the following ip's:
    81.103.221.10

    Is this a problem with my settings or is it a problem with the person I am trying to send to? I have spoken to therecipient and he has told me he is receiving mail from others. [:S]
  8. alexcruzvb

    alexcruzvb New Member

    I am also getting the same error. As a matter of fact I purchased the enterprise edition last week and I receive mails but I cannot send. I am almost giving up.

    Alex
  9. jerger

    jerger New Member

    do you guys have fqdn hostnames setup to your ip address?

    this could be an issue even if you do. we have external ips in our dns records... but smartermail grabs the internal ips from the nic... this causes mismatching in helo tests performed by AOL and other isps... the only way to get around this is to do a non-legal non-fqdn... and just use the domain.com and the internal ip address as your hostname. its kind of messed up.
  10. somsen99

    somsen99 New Member

    In response to some of this. One thing that I had to do was have my hosting provider setup reverse DNS manually for my server that is hosting my SmarterMail. According to my hosting provider, the settings in SmarterMail don't actually setup reverse DNS.
    He could be filling me full of it but once he setup reverse dns I was able to send messages without any problems. I've had very limited problems ever since.
    One thing too about yahoo. I actually sent a request to get my server "whitelisted" as well due to the suggestion from this post: http://www.smartertools.com/forums/p/13531/30700.aspx. It seemed I was having the greatest problem with Yahoo so I would definitely recommend this. Hopefully this helps.
  11. simonpinkney

    simonpinkney New Member

    Strangely enough I also upgraded from Pro to Enterprise though it has been working fine until yesterday and today. The email address I am sending it to has received email from me but now it is bouncing back.

    We have a dedicated server hosted remotely. I spoke with the company hosting this for me this morning regarding reverse DNS and was told that the settings for reverse dns are in the genral settings when you log in through your admin account. I have checked what he told me and mine are set up correctly if he is right.... apparently! The bounce back actually quotes my dns name so I assume this is correct.

    However, I shall ask the question again re reverse DNS and see if this can be manually configured.

    Thanks
    Simon
  12. ramiss

    ramiss Senior Member

    This is correct. Reverse DNS must be setup on a DNS server. This is standard practice (or should be) for any mail server. It is typically done at the datacenter, or wherever the authoritative dns server for the IP resides.

    A lot of people seem to have problems understanding how this check, and the domainkey checks work. When you setup any DNS related item in SM you still need to actually add the records to the proper DNS server.
  13. ST-JLance

    ST-JLance New Member

    The error in question most likely does not have anything to do with DNS. SmarterMail is correctly able to resolve the MX records and get a list of IP addresses to connect to. The problem is that it can not connect to port 25 on these IP addresses. The most common reason for this is either a) Your ISP is blocking port 25 or b) You have a firewall blocking port 25 outbound traffic. In either case, open a command prompt and try to telnet to one of those IP addresses on port 25. If it fails:
    If you have a dedicated server, call up their support and see if they need to adjust their firewalls for your server.
    If you are running SmarterMail through an ISP, call up their support and make sure they allow you to send mail that isn't going through their gateways.
    If it passes, then there is probably a configuration issue with SmarterMail, in which case I would advise you to use one of your free support incidents you got with the purchase of SmarterMail to have one of our support guys take a look at your configuration.
  14. ST-JLance

    ST-JLance New Member

    If SmarterMail is behind a NAT, it doesn't know or care about external IPs. All it knows is that it is listening on the internal IP or sending out messages from that internal IP. The host name to IP mappings only instruct SmarterMail what host name to use when listening on/sending on the IPs that it knows about.
    If your internal IP is 1.2.3.4, and your external IP is 5.6.7.8, and 5.6.7.8 reverses to domain.example.com, then you want to map 1.2.3.4 to domain.example.com.
  15. dycmark

    dycmark New Member

    It is intresting that this error seems to have just come up for me also. I upgraded recently to enterprise but doubt that this is related. I have been managing various mail servers for 15 years and Yahoo in particular is a HUGE pain to deal with they have "brown outs" of mail services intentionally when we see spam and holiday volume surges and then as admins have to waste countless hours explaining to our customers that the problem is not with us and of course the "big box" company always gets the pass.
    That being said we are seeing a higher vilume of bounces than normal and althought i have only been managing smarter mail servers for about 1 year i have never seen a 601 error (at least one has never been reported directly to me). things i know are that our reverses are 100% correct and the other "core configuration" as far as IP's and such is correct. I am just wondering if you remove all of the extranious curcunstances we all have and look at this from a 2 servers connected directly to the internet with no firewalls on either side so routing is direct, If thereis any possibility that the smtp service is having some problem connecting to certian versions of whatever mail server software some of the "big box" providers are using.
    Im not sure this is possible since it seems to be sporadic but based on this post it seems a few of us have this sudden rash of 601s
    Ideas are welcome as we are now getting more complaints from customers than i have time to directly respond to and i hate providing caned responses to problems
    Thanks
  16. jmbishop

    jmbishop New Member

    A few of my clients have also started getting the 601 errors since our upgrade to Enterprise. They are getting this error from government agencies that they have done business with for years with no problems.
    And ideas?
    JBishop
  17. Lieutenant172

    Lieutenant172 Member

    Our mail server can no longer send to Sprint PCS Phones (@messaging.sprintpcs.com).

    Could not deliver message to the following recipient(s):

    Failed Recipient: 3015551212@messaging.sprintpcs.com
    Reason: Remote host said: 601 Attempted to send the message to the following ip's: 68.28.3.22

    We are running in a VPS environment with our own dedicated ip address. We have an SPF record setup as well as RDNS. I have contacted our web host and they advised me that a firewall is definitely not blocking the port. They have been "looking into the issue" for several days now.

    I can telnet to the ip address on port 25 successfully on another VPS server, same web host. I can also telnet succesfully at home. However, if I try to telnet from our mail server, it fails.

    Does this mean that Sprint is possibly blocking us? We have seen a few other 601 errors as well. I'm out of ideas.

    Ron
  18. mbecker

    mbecker New Member

    Hi folks,We recently migrated from Exchange to Smartermail and are now getting the same 601 error.I would appreciate any help in isolating the cause.
    Thanks
  19. bratwurst

    bratwurst New Member

    Same problem here.

    "Reason: Remote host said: 601 Attempted to send the message to the following ip's: "

    This was not an issue at all until we upgraded to 5.5.3216. It is only a few domains, but noticable. I have also saw a few other posts from people with the same error. Hope it is addressed soon.
  20. FTS

    FTS New Member

    Same here

    seems to affect Sprint / Embarq email addresses only.

    smarter tools reply would be appreciated