Resolved SM9 is very slow

Discussion in 'SmarterMail' started by bozo, Feb 22, 2012.

  1. bozo

    bozo New Member

    SmarterMail Enterprise Edition 9.1.4429

    It is very slow to open the message folders.
    It is very slow to login
    There are more errors and programming errors that never ends.

    None of these problems occurred with the SM8. Only with the SM9

    I'm having so much saturated complaining customer.
    Does SmarterTools will solve the problem or delete my post again?
  2. vantucko

    vantucko New Member

    Just an observation. You may want to include any relevant technical information to support your request. Just saying something is broke does nothing to help solve an issue. While you may be frustrated, posting like this will get you nowhere.

    Cheers
  3. chicagonettech

    chicagonettech Product Expert

    Server configuration:

    Operating system?
    Memory?
    Hardware configuration?
    Drive configuration? SATA | IDE | RAID
    To what drive is the program installed?
    To what drive is DATA mapped?
    How many domains?
    How many accounts?
    How big are the mail boxes?
    Are you running the built in SmarterMail IIS or are you running IIS 6 or IIS 7?
    Do you have ALL patches installed for the network operating system, including the ELECTIVE patches?
    Are you running any kind of active antivirus scanning on the server, if so, what?

    All of your responses to these questions will play a roll in the responsiveness of your server and SmarterMail.
  4. bozo

    bozo New Member


    Operating system?
    Windows server 2003 R2 st 32 Bits

    Memory?
    4 GB

    Hardware configuration?
    Drive configuration? SATA | IDE | RAID
    SATA RAID 10

    To what drive is DATA mapped?
    other, no OS

    How many domains?
    700
    How many accounts?
    2000

    How big are the mail boxes?
    MAX 2 GB (few accounts)

    Are you running the built in SmarterMail IIS or are you running IIS 6 or IIS 7?
    IIS 6

    Do you have ALL patches installed for the network operating system, including the ELECTIVE patches?
    YESSSSSS

    Are you running any kind of active antivirus scanning on the server, if so, what?
    NO

    The most important:
    None of these problems occurred with the SM8. Only with the SM9 (SmarterMail Enterprise Edition 9.1.4429)
  5. DXD

    DXD Product Expert

    Is SmarterMail the only thing on this server?
  6. bozo

    bozo New Member

    Yes! Only SM9
  7. DXD

    DXD Product Expert

    Have you done any performance monitoring when you see it's slow? Is it just the webmail that's slow?
  8. bozo

    bozo New Member

    Some additional information:
    Avg. CPU: 3 percent
    Avg. memory: 151 MB

    The CPU and memory usage is very low.
    I can not understand slowness in webmail.
  9. DXD

    DXD Product Expert

    Your server is only using 151 MB or Ram?

    Have you tried multiple browsers? Can you provide a login so I can see?
  10. dandickson

    dandickson Member

    disk fragmentation?
  11. bozo

    bozo New Member

    No. I use O&O Defrag 15 Server Edition.


    The most important thing I've said and I repeat

    None of these problems occurred with the SM8. Only with the SM9


    In short. Something has changed from version 8 to 9 that causes the problem of slowness in webmail.
    I use SmarterMail since version 3.
    But the technology used in the webmail version 9 is slow, very slow.
  12. nkuzman

    nkuzman New Member

    Have you tried to monitor SmarterMail indexing or disabling indexing completely?
    http://portal.smartertools.com/KB/a...ature-to-enhance-searching-capabillities.aspx
    Monitor logical and/or physical disk performance with Performance monitor console (Disk queue length and % Disk time counters).
  13. chicagonettech

    chicagonettech Product Expert

    You should be excluding the SmarterMail directories. There is way too much activity going on in those directories to run a defrag.

    You may also want to consider running the defrag only during NON-PEAK periods.

    Remember, any e-mail server is DISK I/O intensive and needs 100% of the server resources 100% of the time. When you introduce ANY other program or service on the same server as an e-mail server, you take away from resources which should be dedicated and available to the e-mail server.

    Defrag software is especially disk I/O intensive, and can introduce significant slowdown in any device on which is it running.
  14. Wheemer

    Wheemer Product Expert

    I think he was running the same defrag software with version 8 without the slowness.

    I am running diskeeper 2011 and it seems to be doing fine with my smartermail install.
  15. bozo

    bozo New Member

    Correct.
    Defragment only on the limited access (Sunday).
    The programming used in SM 9.1 to view messages is slow
    Where is slow with 200 or more users in webmail.
    SM8 or less did not have this problem ... I use the SM since version 3
  16. DXD

    DXD Product Expert

    At this point I don't see you finding much help from the users here, your probably better off opening a support ticket with SmarterTools
  17. Kristian Wind

    Kristian Wind New Member

    Removing and reinstalling .Net helped my server going from 100% CPU and lots of memory use to very little... Don't know if this is the case here. It was after I upgraded to SM9 that this was an issue.

    I used this tool: http://blogs.msdn.com/b/astebner/archive/2008/08/28/8904493.aspx

    The SmarterMail application pool will probably reset back to .NET 2.0, and will need to be reset to .NET 4.0.

    Took me 2 minutes and it works perfectly now.

    /Kristian
    Nolimit.dk


    ADDED: This also helped with the speed of the server in general from next to stopped to lightning speed... The link and recommendation came originally from SmarterTools support.
  18. Webio

    Webio Active Member

    Hello,

    have you maybe found out what can cause slowness of SMv9?

    Regards
  19. Peyman

    Peyman Member

    Hello,

    We'd upgrade our 5 mail servers to SM9.1 10 days ago but we found they became very slow. Number of mail in the spool increased and users complainted that they can't open the webmail. We monitored the servers resources and found CPU and Disk Queue lenght were high. (Avg. CPU usage was about 80% and Avg. Disk Queue length was 25!). So we downgraded to v8.4 again and all issues have been resolved. Current CPU usage is 20% and Disk Queue length is about 2.
    This shows that there is a problem in Smartermail and it is not related to hardware

    Thanks
  20. chicagonettech

    chicagonettech Product Expert

    How many domains and mailboxes?

    Smartermail made a MAJOR file structure change at version 8, and conversion requires a lot of server work on the initail install.




    Sent from my HTC EVO 4G/PC36100 using Tapatalk on the 4G Now Network from Sprint!