1. This forum is read-only and considered to be an Archive. Please utilize the SmarterTools Community for future interaction and posts.

SM Web Page not showing after upgrade

Discussion in 'SmarterMail' started by markboler, Apr 4, 2012.

  1. markboler

    markboler New Member

    I just upgraded my SM installation from v 3.x to 9.2.

    the upgrade went well. Changed to .NET 4.0 and it installed and seemed to index well. I got into the interface with IE and enterred my registration code. It accepted it, and is running and handling email, in and out just fine. So .NET 4 is working and IIS is working and all just fine. Or at least it was.

    Now, when I try to get into the web interface, using domain name:9998 it just sits there, waiting and waiting. This is with IE, or Chrome.

    I have let it sit for 20 minutes and still nothing. This is either from remote, or even on the server machine using IE and localhost. Not a thing comes up in the browser window. I did see the interface in order to enter the registration and was looking at the items. But clicking on one brought up a popup and the popup showed nothing.

    I am running Windows server 2003. 64 bit, 4G RAM, 300 Gig hard drive space on install with 213 gig free. Task manager showing about 4 or 5 percent utiliization.

    IIS is set up fine, and it it using .NET 4.0 app pool. Tried rebooting, recycling the app pool. Restarting IIS, killing coookies in the browser, etc. Nothing will bnring up the web interface.

    thanks

    Mark
  2. DXD

    DXD Product Expert

    Have you made sure the SmarterMail webservice is stopped and disabled since you are using IIS. Also check the bindings in IIS for the SmarterMail website to make sure they are correct.
  3. markboler

    markboler New Member

    Yes, that has all been checked. So I recycled the .NET 4 app pool. Once I did that, it started working, and now it's not working again. I guess I'll next try to create my own dedicated .NET 4.0 app pool for SM to run in, and make it recycle every once in a while.

    Does that sound right? Or is something else possibly wrong?
  4. DXD

    DXD Product Expert

    If you read the installation instructions in the KB it will tell you that you should be running SmarterMail in it's own apppool anyways.
  5. markboler

    markboler New Member

    Ah, ok. But the KB I read about upgrading didn't mention that. I usually give anything in a .NET seperate directory it's own app pool. I just didn't get to it yet.
  6. chicagonettech

    chicagonettech Product Expert

    From: http://portal.smartertools.com/KB/a...-as-an-iis-site-iis-60.aspx?KBSearchID=445007

    Add an Application PoolFollow these steps to add an application pool:
    1. Click on Start -> Control Panel -> Administrative Tools -> Internet Information Services (IIS) Manager.
    2. Right click on Application Pools and choose New -> Application Pool.
    3. Name the pool SmarterMail (or something equivalent) and click OK.
    4. Click Close.