Reason: Remote host said: 601 Attempted to send the message

Discussion in 'SmarterMail' started by milesb, Oct 1, 2013.

  1. milesb

    milesb New Member

    ok, I have a wierd one here. I run my mail off Smartermail 11, along with various other clients of mine.

    Whenever anyone on my server sends mail to @sunflora.co.uk the following happens

    1. The mail IS delivered
    2. The sender gets a Delivery Failure message as below.

    Delivery Failure
    Reason: Remote host said: 601 Attempted to send the message to the following ip's: 78.32.146.34



    I know port 25 is open the other end otherwise they wouldn't get the mail. I lookafter the mail server the other end too which is Exchange 2010. This is only happening to people sending from my SM install, so it's something to do with SM.

    Any pointers appreciated.

    Thanks
  2. scrupul0us

    scrupul0us Active Member

    Usually that kickback would indicate that your server cannot talk to that IP.

    How long does it take to deliver the email, e.g. does it sit in your queue and deliver after retries?

    Can the destination end provide any kind of logs to show how your server IP is transacting with it?
  3. milesb

    milesb New Member

    that's what I thought, except the messages ARE received the other end in normal time (i.e. within a few mins of sending) - I'll try and look at the Exchange logs - very odd...
  4. pjeski

    pjeski Member

    I tried sending an email. I got a timeout. The last few lines of my delivery log are:
    07:27:33 [15856] RSP: 250 2.1.0 Sender OK
    07:27:33 [15856] CMD: RCPT TO:<postmaster@sunflora.co.uk>
    07:27:34 [15856] RSP: 250 2.1.5 Recipient OK
    07:27:34 [15856] CMD: DATA
    07:27:34 [15856] RSP: 354 Start mail input; end with <CRLF>.<CRLF>
    07:28:34 [15856] The smtp session has timed out.
  5. milesb

    milesb New Member

    I can do an MX check here http://mxtoolbox.com/ on the sunflora domain and it's fine

    Also they ARE receiving email, including ones I send. Just when I send via SM I get that 601 back in my inbox. I'm 99% sure it's the SM end of things getting upset here
  6. milesb

    milesb New Member

    the message I get back (with some details removed) is

    Reason: Remote host said: 601 Attempted to send the message to the following ip's:


    78.32.146.34

    -- The header and top 20 lines of the message follows --

    Received: from MYPCNAME ( [xx.xx.xx.xx]) by my.smartermailserver.co.uk with SMTP


    (version=TLS\Tls


    cipher=Aes bits=128);
  7. Wheemer

    Wheemer Product Expert

    Is there anything in front of that exchange server? spam device?
  8. pjeski

    pjeski Member

    I increased my command timeout for SMTP Out from 60 to 240 seconds.

    Now it looks like it delivers.

    15:02:08 [16059] RSP: 250 2.1.0 Sender OK
    15:02:08 [16059] CMD: RCPT TO:<postmaster@sunflora.co.uk>
    15:02:09 [16059] RSP: 250 2.1.5 Recipient OK
    15:02:09 [16059] CMD: DATA
    15:02:09 [16059] RSP: 354 Start mail input; end with <CRLF>.<CRLF>
    15:03:10 [16059] RSP: 250 2.6.0 <2bb5d0f4$21e4f0a2$53e271eb$@ncsmail.com> [InternalId=8349] Queued mail for delivery
    15:03:10 [16059] CMD: QUIT
    15:03:10 [16059] RSP: 221 2.0.0 Service closing transmission channel
    15:03:10 [16059] Delivery for Postmaster@ncsmail.com to postmaster@sunflora.co.uk has completed (Delivered)
    15:03:13 [16059] Delivery finished for Postmaster@ncsmail.com at 3:03:13 PM [id:89516059]


    Also looks like this one was one second over the old timeout.
  9. milesb

    milesb New Member

    I've whitelisted the IP at the exchange end and now it's ok - really odd, never known exchange to accept a message and reject at the same time ?!?!
  10. pjeski

    pjeski Member

    From what my logs showed of the two emails I sent, exchange wasn't rejecting the email but the Smartermail was timing the command out. The longer time seemed to fix it at my end, but I don't know if you received the second email I sent. (the one that appeared to be successful)
  11. chicagonettech

    chicagonettech Product Expert

    Who are the ISP providers at each end, IT: the ones who provide the bandwidth to the two servers?

    We saw this with a major ISP a few years ago when Comcast upped their MTU from 1492 to 1500 during the DATA EXCHANGE portion of e-mail transactions. They handled all of the handshaking and negotiations at 1492 and everything talked. Once the Comcast mail server jumped the connection to 1500, everything hung.

    In that case, it was an interconnect who's core routers could not handle the change in packet sizes and simply hung. We attempted to work with them and, after a couple of months, advised the customer to break their contract and get a new bandwidth provider - they did, problem solved.

    So I would start by doing some tracert tests with an MTU size of 1500 - between the two locations, and then seeing if the trace hangs at any point along the route. If it does, that may be your issue.

    I would also check all of the routers, firewalls, and switches used at both locations.

    Hanging connections can be difficult to troubleshoot so keep your hands away from your hair as that may be the think you pull in frustration as you look further into the problem.