People Sending Me Email Get Remote host said: 550 Authentication is required...

Discussion in 'SmarterMail' started by chammock, Oct 12, 2011.

  1. chammock

    chammock Member

    A few weeks ago I implemented the recommendations on this forum to cut down on spam in including the barracuda RBL. It worked great. But now I am finding some people who were able to email me are getting their emails bounced back with this type of error.

    Connected to 70.34.32.254 but sender was rejected.
    Remote host said: 550 Authentication is required for relay

    Is there a setting I need to do to make sure people are able to email me?

    Also, I have one client who said that he can email the rest of the world fine, but when he emails his wife on the same domain they don't get through.

    Any ideas on if I did something wrong?
  2. DXD

    DXD Product Expert

    Knowing the domain the email is coming from and the domain is going to would help us better investigate your issue.
  3. Alex Clarke

    Alex Clarke Member

    I ran into this issue the other day (internal emails bouncing). It turns out that a couple of client's were using their ISP SMTP servers instead of ours. I added these to the SMTP Authentication Bypass list and the problem went away.

    Hope this helps,

    Alex
  4. DXD

    DXD Product Expert

    This would only apply if the where the from and to domains were hosted on the same SmarterMail install. The OP didn't indicate if this is the case.

    If it is the clients should use the OP's SMTP server and not their ISP's. If the ISP is blocking port 25 (a lot do now) then the OP should setup an alternate port (587 is the standard) and the clients should use that.

    As a warning setting the ISP's SMTP server to by pass relay could be a security issue. If the Client's are not being authenticated by the ISP when their SMTP server is used then ANYONE could use it to send spam. If they are being authenticated but are not enforcing strong passwords accounts could get hacked and again SPAM could be sent causing the OP's servers to be blacklisted.
  5. chammock

    chammock Member

    Thanks for your replies. For the first issue, I have a person sending me email from dreisner.com (their domain with email from GoDaddy) to theforerunnernetwork.com domain (my domain using SmarterMail). These are the ones getting this error.

    Connected to 70.34.32.254 but sender was rejected.
    Remote host said: 550 Authentication is required for relay

    For the other situation, I know my client and his wife, who are on my smartermail are both using Outlook and there was some issues in the past regarding which SMTP server to use. They were having some issues sending email from Outlook, so I think they reverted to using their AT&T or Cox SMTP settings. If you can provide some more details on how I should set this up and what SMTP settings they should be using in Outlook for the best security I would very much appreciate it.
  6. DXD

    DXD Product Expert

    Since you don't host dreisner.com I am thinking we need to know what the are using for their SMTP settings for sending email with that domain. From what I can tell they are not using godaddy for email unless smtp.secureserver.net belongs to GoDaddy.
  7. chammock

    chammock Member

  8. chicagonettech

    chicagonettech Product Expert

    Aside from the fact that you have both of your DNS servers on the same class "C" subnet - which is not a technical violation, but could cause you not to be found if that network went down, your DNS, e-mail and web hosting setup is extremely clean.

    The following link is good for 7 days [until 20 Oct, 2011] and will let you review the test I just ran: http://www.dnsstuff.com/tools/dnsre...s=true&token=2651337d7989a1d826b50f121d4e1015

    The person sending to you has two MX records, both on the same IP ADDRESS:

    20 mailstore1.secureserver.net. [TTL=7200] IP=216.69.186.201 (No Glue) [TTL=300] [US]
    10 smtp.secureserver.net. [TTL=7200] IP=216.69.186.201 (No Glue) [TTL=300] [US]

    and the testing site I used to run both domains shows this as an error:

    WARNING: You have duplicate MX records. This means that mailservers may try delivering mail to the same IP more than once. Although technically valid, this is very confusing, and wastes resources. The duplicate MX records are:

    mailstore1.secureserver.net. and smtp.secureserver.net. both resolve to 216.69.186.201.

    They also have valid REVERSE DNS entries:

    201.186.69.216.in-addr.arpa m1pismtp01-v01.prod.mesa1.secureserver.net. [TTL=1864]
    201.186.69.216.in-addr.arpa m1pismtp01-v01.prod.mesa1.secureserver.net. [TTL=1864]

    . . . again, both reverse DNS entries point to the same IP address, and the same mail server, MESA1.SECURESERVER.NET

    It MAY be the cause of the issue from them, but I have never seen this cause this kind of error before.

    The issue for your rejection, and this is only if you have very specific anti-spam settings in place, may be the fact that the HOST NAME for theri mail server shows radically different than their MX servers with a DIFFERENT IP ADDRESS than they have posted in their DNS:

    mailstore1.secureserver.net claims to be host m1pismtp01-002.prod.mesa1.secureserver.net [but that host is at 216.69.186.2 , not 216.69.186.201]. <br />smtp.secureserver.net claims to be host m1pismtp01-008.prod.mesa1.secureserver.net [but that host is at 216.69.186.8 (may be cached), not 216.69.186.201].

    You may want to contact the owner of the domain having problems sending to you and share this information with them.
  9. chammock

    chammock Member

    I now have a couple of important clients who cannot send mail to me. And now they cannot receive email from my server. One client has email hosted on my smarter mail server with my email and the other has Godaddy email. The only thing I can find in common is they both use Outlook. I implemented the alternate SMTP port 587 and had the client add that to his outlook setup per some instructions I found online. But still not working.

    Is there anything I can undo related to the anti spam setup that I followed from these forums that will provide some temporary relief until I have time to resolve this properly?
  10. DXD

    DXD Product Expert

    Have you looked at the smtp logs to see why the emails are not being delivered? Is it possible that either their mail server or their client IP's are being blocked because of spam?
  11. eschaefer

    eschaefer New Member

    Is "Disable relay settings when using SMTP authentication" unchecked in Settings -> Protocol Settings -> SMTP In? If so check it and test

    -Ed