1. This forum is read-only and considered to be an Archive. Please utilize the SmarterTools Community for future interaction and posts.

Natted Smartermail

Discussion in 'SmarterMail' started by Wheemer, May 8, 2012.

  1. Wheemer

    Wheemer Senior Member

    Hello;

    Is it possible to run Smartermail behind a firewall using NAT?

    I currently am running a smartermail install like this, but I am using an external gateway to send email through.

    We are getting a new internet connection soon, so I am preparing for it.

    With this new connection I will finally be able to have an external IP that has rDNS and PTR setup properly.

    However we are implementing the new internet connection with a plan to no longer use DMZ.

    I'm wondering if I can manually edit the xml to add the new external IP and still keep Smartermail behind NAT.

    Anyone have a similar setup?
  2. brianlewis

    brianlewis Product Expert

    Smartermail configure it for the internal ip for binding on the domain
    Configure the NAT rules to allow outbound (typical)
    Configure inbound NAT rule for port 25,110,143,9998, and any other ports you need like 80 or secure smtp/pop3/imap to redirect back to the private ip of the Smartermail server
    Will work just fine, be sure to update smartermail for new providers dns servers
  3. I'm currently running 2 email servers behind a 1to1 NAT with no noticeable problems. Not sure about basic NAT with 1 public though.
  4. bcconner

    bcconner Member

    We've run SM fine for years behind a NAT firewall/router with no problems. Setting up the passthrough ports is the biggest hassle. When setting up SM, you would use the internal IP addresses assigned to that box. You can test it by putting in the internal IP address of SM once you get it up. If it is on a shared server you would need the header info, in which case you would want to put an entry in your hosts file to allow your browser to point to the internal IP address along with the domain name.

    --Ben
  5. Wheemer

    Wheemer Senior Member

    Thanks guys... I was worried that smartermail would report the internal IP instead of the external one when sending mail.
  6. DXD

    DXD Product Expert

    I thought it did and I'm pretty sure I've seen other people report this as a problem for them as well, that SmarterMail would always use the private IP instead of the public IP
  7. brianlewis

    brianlewis Product Expert

    Report what? There is nothing in the smtp protocol to report an ip address. This is not FTP, its not reporting an ip/port for the transfer of data. The NAT router handles the translation of the source/target for outbound/inbound packets.
  8. Wheemer

    Wheemer Senior Member

    OK... that makes sense. That's why I was asking because I remembered something about there possibly being a problem...

    Should be good to go once our new connection is live.

    Thanks!