Mozilla Thunderbird receives email but can't send!!!

Discussion in 'SmarterMail' started by Edward32, Apr 16, 2007.

  1. Edward32

    Edward32 New Member

    I can't get Thunderbird to send any emails. Any ideas....I am using outlook and would love to switch to thunderbird with smarter mail.
    thanks
    Edward
  2. mgraveen

    mgraveen Member

    What error(s) are you getting?
    Mike
  3. Edward32

    Edward32 New Member

    server not responding: authentication required for relay....does that help?
  4. slalomdrew

    slalomdrew Active Member

    It appears your mail server requires users to use SMTP authentication when sending to an address hosted on a machine other than the local server. You should make the proper changes in thunderbird.
  5. Edward32

    Edward32 New Member

    ok so now its sending mail but where I'll never know. They never reach their destination.....Here are some of my settings:
    server settings: Use server connection, never is checked....unchecked also is the use secure authentication.
    Outgoing server settings: user name and password is checked, use secure connection no is checked.

    Any ideas.????????
  6. mgraveen

    mgraveen Member

    Check your mail server logs to see where it's going. If your mail server is accepting the mail from Thunderbird, then I would use the logs to see what's happening.
    Mike
  7. DavidJBerman

    DavidJBerman New Member

    I'm having the same problem. It started when I realized that my SmarterMail 4.x server didn't default to requiring SMTP authentication. Once I turned that on I noticed that my mail email account can't send SMTP mail anymore. I don't get any errors. I can send email to other domains serverd by this mail server, but it won't deliver my email anywhere else.
    The SMTP log shows the server receiving the email and it looks like its writing a .eml file. However, it doesn't show up in the Delivery log. I also noticed it only happens with this one account, all others seem to be fine.
    Disabling require SMTP auth doesn't correct the problem. I also tried disabling DKeyEvent SM to not effect.
    I also tried deleting the email account and recreating it.

    This problem is becoming urget. Can anyone offer advice as to how to diagnose this problem?

    Thank you.

    David

    [[ EDIT: I'm having the same problem with Outlook AND Thunderbird, but if I use the web mail interface I have no problems sending mail ]]
  8. ST-DOhare

    ST-DOhare New Member

    The e-mail client has to Check My outgoing server (SMTP) requires authenticationWhen setting up the e-mail client make sure that the Logon Information in your account uses your complete email address i.e. test@example.com.
  9. DavidJBerman

    DavidJBerman New Member

    Thank you ST-DOhare for your reply. My email client (I tried both Outlook and Thunderbird)are configured to use the full email address and use SMTP authentication. I'm using an alternate SMTP port. I also have several domains and most email accounts work fine. I have in Outlook 5 different email accounts on the same and other domains, all configured the same way. When I try to send email I don't get any error messages and the message doesn't bounce back or anything. It just never gets to the destination. I even created a new account and the new account had the same problem. I also tried turning "Require SMTP authentication" off again for my SmarterMail 4.x server and the problem continued.
    Anything else I could check?
    David
  10. ST-DOhare

    ST-DOhare New Member

    Make sure your SMPT and Delivery logs are set to detail.You should be able to find the message in the SMTP logs and follow the message through to the delivery logs. The delivery logs will indicate if the message has been delivered or filtered in some manner.
  11. DavidJBerman

    DavidJBerman New Member

    Thanks again ST-DOhare. I think I understand how the logs work now. The SMTP log writes the received email with an ID, for example 96842829050.eml. You can then search the delivery log for that number (without the .eml on the end). The delivery log puts a time stamp on each line with a serial number for all related log items in [xxxxx]. Here's what I'm seeing:
    10:22:28 [29050] Delivery started for <<my email>> at 10:22:28 AM
    10:23:28 [29050] Sending remote mail for <<my email>>
    10:23:47 [29050] This message cannot be delivered as it was marked as spam.
    10:23:49 [29050] Sending remote mail for <<my email>>
    10:23:54 [29050] This message cannot be delivered as it was marked as spam.
    10:23:55 [29050] Delivery finished for <<my email>> at 10:23:55 AM [id:96842829050]
    Ok so why is my email being marked as spam? I went in the Plesk settings and tried to add my emal to the white list but it didn't help. Also I tried changing my outbound SMTP server to a different domain name on the same machine (smtp.socialnetwork.com instead of smtp.sendtoperson.com) and I was then able to send some emails out. I tried turning back on the DSEventKey option in the spooler settings, and after that I couldn't send email anymore on that account. I turned DSEventKey to disabled in the spooler tab, saved...still cant' send email. Finally I went and restarted the web server, and tried to send email again, but it's still being rejected as spam.
    Why is my server thinking I'm a spammer? How do I correct this problem? Thank you.

    David
  12. ST-DOhare

    ST-DOhare New Member

    Check, the raw content of the message, it will tell you what spam check the message failed You may want to review this knowledge base articleHow To - Recommended SPAM Settings for SmarterMail 4.x and higherhttp://www.smartertools.com/portal/KB/a77/how-to-recommended-spam-settings-smartermail-4x-higher.aspx
  13. DavidJBerman

    DavidJBerman New Member

    Thanks for the link in the article. I reviewed the spam settings. However I can't tell what in my email is causing it to be rejected. How can I check the raw content of the message? It doesn't get delivered so how can I see what the spam screening says? Thank you.
  14. ST-DOhare

    ST-DOhare New Member

    Opening a support ticket with SmarterTools support team is probably a good option now. A visual of your logs and settings will solve your issue very quickly.
  15. ramiss

    ramiss Senior Member

    I would just turn off Spam Blocking for Outgoing mail until you can figure out what spam settings are causing the block.
  16. DavidJBerman

    DavidJBerman New Member

    Will do. Does anyone know where there is information on how to examine the output of the spam filter? I have logs set to full verbosity but the spam analysis output isn't in there. When mail is flagged as spam it is deleted, so I'm not sure how to figure out what I need to change (or why this has so suddenly become a problem).
  17. mgraveen

    mgraveen Member

    Until you solve the issue do not delete the SPAM, just tag it. That way you can look at the headers of the email as see what's going on.

    Mike
  18. DavidJBerman

    DavidJBerman New Member

    At this point the question about why I can't send email with Outlook / Thunderbird has been answered so if I have issues about spam settings I'll move that to a new thread. Thank you everyone for your help, it has made a big difference for me!
  19. Hazzel

    Hazzel New Member

    Hi All,

    Im experiencing the same error.

    This is the message I'm receiving when I'm sending an email:
    Sending of message failed.
    Please verify that your Mail & Newsgroups account settings are correct and try again.


    ---------------------

    What should I do?

    Please help me fix this.

    I would really appreciate any response.

    Thanks,
    Hazzel
  20. elalcaudon

    elalcaudon New Member

    Check your mail server logs to see where it's going.