Bug/Issue Moved SmaterMail 9 to New Server - Cannot Connect from any Ohter IP than localhost

Discussion in 'SmarterMail' started by bbqchickenrobot, Mar 19, 2012.

  1. bbqchickenrobot

    bbqchickenrobot New Member

    Just moved a working installation of smarter mail 9 to a new server and followed the instructions here to the tee:

    http://portal.smartertools.com/KB/a...-to-a-different-server.aspx?KBSearchID=440705

    However, after the migration I cannot connect to any ports (IMAP,POP3,SMTP) from any other IP/name than localhost on the new server. I can telnet into from the localhost name (telnet localhost 25). The firewall is configured properly as I can disable smartermail service and enable the MS SMTP service and the outside world can connect no prob. My new installation/migration passes all self diagnostic tests..

    Somehow SMarterMail is blocking connections from the public and private IPs.

    Working:
    telnet localhost 25

    Not Working:
    telnet mx01 25
    telnet mx01.mydomain.com 25

    Host Windows Server 2008 R2 running SmarterMail 9.2 (Old version/host was SmarterMail 9.0 on Win2008R2)
  2. chicagonettech

    chicagonettech Product Expert

    If you post your real domain name we can test from outside. Without the actual domain name there is little we can do to assist you.
  3. bbqchickenrobot

    bbqchickenrobot New Member

    Figured it out!

    There were a new set of IPs that need to enable the ports on within SmarterMail... once done, everything worked, should update the KB entry to tell new users about this !!

    In SmarterMail (logged in as admin) go to Settings | Bindings | IP Addresses and then edit the NEW IPs that pertain to the newly migrated server and enable them! Done! If this was in KB it would have saved me 2 hours...
  4. crystalh

    crystalh New Member

    after updating to version 10 Outlook couldn't send receive for SM server domains

    Thank you for your post! I just upgraded to SM 10 Pro and none of my domains' accounts could send/receive in my Outlook 2010 or on my Android phone but webmail worked fine. I followed your suggestions and although I didn't have new IPs to add, I chose my outgoing IP and clicked Edit and could see I needed to check the boxes for POP & SMTP and saved and then it worked. I'm so glad you took the time to post your solution because it helped me too.