Helo command rejected: need fully-qualified hostname

Discussion in 'SmarterMail' started by jp, Nov 25, 2004.

  1. jp

    jp New Member

    Hi guys,

    I get the following error when trying to send mails to one of my friends.

    Could not deliver message to the following recipient(s):

    Failed Recipient: user@domain.com
    Reason: Remote host said: 504 <mailserver>: Helo command rejected: need fully-qualified hostname

    My server is a Windows 2003 server, which has been named "mailserver", but I have also told it to use a primary DNS suffix, so in System Properties, Computer Name tab it says: mailserver.mydomain.com. This domain name is registred as an A-Record in the public DNS.

    The primary DNS suffix was not set up at the time the SmarterMail Professional 2.0 was set up, so I am wondering if there is somewhere I need to write the fully qualified domain name in the mailserver. I just can't find the place to do it.

    Thanks in advance!
    Joe
  2. camilo-rf

    camilo-rf New Member

    You have to put a FQDN in the General Settings of SM2.
  3. diego

    diego New Member

    I have a similar problem. My question is... I am hosting several mail domains. If I enter only one of them in the general setting, what happens to the others?Or is there any way to list FDQNs for all mail domains on the machine?How does it works?Any suggestion?
  4. diego

    diego New Member

    I also use multiple IPs for mail domains, while some other domains are just virtual, pointing at one IP.
    Let me post the error message:
    Failed Recipient: usersomeone@someoneelsedomain.comReason: Remote host said: 501<MYSERVERNAME>: Helo command rejected: need fully qualified hostname
    That's why I know that I have to enter a FQDN in general settings instead of the machine name as it is set up now. But is there a way of adding more FQDNs in the general settings of smartmail? Maybe comma divided, or... anything?Even if I add 1 FQDN I am going to solve the problem on one domain, but not on the others.Also, if my machine has multiple IPs... which mail domain should I add there???
    I also left blank the IP of primary and secondary DNS in general setting.
    Also, my DNS records and MX records are correct.It is really a SM related issue. SM answers with the default HELO. Any way to hack this?I was browsing through different posts and there was some talk about adding an HELO option for every single domain...SM is able to handle different IPs, there must be a way to force domains HELOs as well.Any news about that?If I leave blank the general setting server name, what happens? SM will answer with the proper domain name?
  5. ST-JLance

    ST-JLance New Member

    The Host Name field in the General Settings is the Fully Qualified Domain Name of the mail server. It does not need to be the same domain name as any of your hosted mail domains. For example, if I host domain.com and mydomain.com, I can name my server mail.MyHostingCompany.com. It does not need to reflect any of my hosted domains.

    To make sure you will not have any delivery problems, make sure that mail.MyHostingCompany.com resolves to an IP address in your control. Then, set up a reverse dns record for that IP address that resolves back to mail.MyHostingCompany.com. That is all you need to do to ensure proper delivery.
  6. diego

    diego New Member

    Thanks, that's a relief.
    I left the IP of primary server blank in the general setting.If I specify the host name, do I have to specify its IP address in one of the boxes below, or can I leave them blank?
  7. tcraig

    tcraig New Member

    I wanted to followup on this. My Settings > General Settings > Host Name is what it should be (mail2.nextmeta.com), but the helo is still showing the computer name. This is version 3.3.261 on Windows 2003 and IIS 6.

    So, if the host name is correctly set, shouldn't it be reflected in the helo? If it should and yet is not reflected, what needs to be done?

    Another poster mentioned changing the actual computer name of the server to mail2.nextmeta.com. Is that necessary?

    Thanks,

    Tom
  8. jerger

    jerger New Member

    we have 15 domains... hosted on smartermail... all of them are hosted on one mail server... their dns records are all hosted on one server (different server)..

    the main domain when we set it up asked for the fqdn, which is kind of retarded since it broke our dns records...
    etp.etradepress.com

    should we have hostnames for each subdomain example..

    etp.cleanhound.com which is a different domain/mx record/server under cleanhound.com in our dns records... the fqdn for the mx record is etp.cleanhound.com

    however after setting up the host records to reflect the fqdn instead of just domainname.com it is now saying the wrong helo!
    etp.cleanhound.com is not etp.etradepress.com but etp.etradepress.com is given from smartermail as the helo! frustrating