1. This forum is read-only and considered to be an Archive. Please utilize the SmarterTools Community for future interaction and posts.

Error need fully-qualified hostname when trying to send an email

Discussion in 'SmarterMail' started by giroin, Sep 18, 2010.

  1. giroin

    giroin New Member

    Hello,

    I got the SmarterMail Professional Edition 7 installed on a VPS windows server 2008 with IIS 7.5 server. Email accounts seems to be working properly for the last week until this evening where tried to deliver a message to a friend and get this error.

    Could not deliver message to the following recipient(s):

    Failed Recipient: hakan@familjen-palm.se
    Reason: Remote host said: 504 5.5.2 : Helo command rejected: need fully-qualified hostname

    -- The header and top 20 lines of the message follows --
    Received: by MASTER-WIN2K8R2-ENT via HTTP;
    Sat, 18 Sep 2010 09:16:31 -0400
    From: "Chania Vacation"
    To:
    Subject: villa Oasis
    Date: Sat, 18 Sep 2010 09:16:31 -0400
    Reply-To: reservations@chania-vacation.com
    Message-ID: <248b1706$7b4284d4$36ec4779$@com>
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_NextPart_000_0001_3DAFE8.22F19670"
    X-Originating-IP: [92.119.181.84]
    This is a multipart message in MIME format.
    ------=_NextPart_000_0001_3DAFE8.22F19670
    Content-Type: text/plain;
    charset="us-ascii"
    Content-Transfer-Encoding: 7bit

    Any ideas where to look at.

    Cheers,

    Giorgos
  2. ST-MKellogg

    ST-MKellogg New Member

    It's likely that you need to set up the hostname for your server. This can be done in General Settings. Under the server info tab, verify that the hostname is set to a fully qualified domain name. If you have multiple IPs on the server on which you connect outbound to send SMTP traffic, you may want to use the hostnames page to configure IP specific hostnames.
  3. giroin

    giroin New Member

    Hello and thanks for your response,

    At the moment the settings are

    Hostname: MASTER-WIN2K8R2-ENT
    I also got two ips on

    IP of Primary DNS: 72.18.139.226
    IP of Secondary DNS: 72.18.139.227

    Should the hostname be something like that? mail.streotropism-hosting.com if yes can it be any available domain from my VPS?
    There is also another question. I dont know if the guys that set up the smarter tools have added all these. Because these ips are not the same with the one I use for my DNS.

    At the moment I got two ips one for the *, www and ftp A records which is the 173.248.128.243 and one for my mail, mail2 which is the 173.248.128.235.

    Please let me know what should I change on that screen.

    Regards,
    Giorgos
  4. chicagonettech

    chicagonettech Product Expert

    Your HOSTNAME should be the same as the A record in your DNS which points to the PRIMARY MAIL SERVER, ie:

    If your A record in DNS points to MAIL.YOURHOSTINGCOMPANY.COM with an IP ADDRESS of 123.234.221.199; and your

    MX record points to MAIL.YOURHOSTINGCOMANY.COM;

    then your SMARTERMAIL HOST NAME should be MAIL.YOURHOSTINGCOMANY.COM with an IP ADDRESS of 123.234.221.199

    Note that 123.234.221.199 will also need to be bound to the NIC which is plugged into your network and that network will require a connection to the outside world.

    Host names are not something random you can pull out of a hat.

    Everything must MATCH what is in the DNS according to IETF STANDARDS. see: www dot ieft dot org

    The STANDARDS are there to make everything WORK.

    Even though most everything is now GUI based, you may also want to pick up a copy of DNS AND BIND. It will give you a good basic overview of DNS system, how it works and WHY it works the way it does. Once you have done that, there are good online resources for every server operating system and SmarterMail has an excellent installation guide on their website.