Delivery Failure

Discussion in 'SmarterMail' started by peteboyd, Nov 6, 2004.

  1. peteboyd

    peteboyd New Member

    I am getting a strange delivery failure. I recently added a domain to our smartermail email server. I then removed the domain because the client ended up hosting the email elsewhere. Before I added the domain I was able to send email to the client. Now that I added and removed the domain name I get a delivery failure. The client gets mail from everywhere but our email server.

    Any ideas? I am thinking that my system is still trying to send the email to our email server because the domain wasnt truly deleted. However, it is not listed as a domain in the admin panel. Where should I look to solve this issue or what other ideas does anyone else have?

    Listed below is the message delivery failure that was returned.

    ------------------------------------------------------------------

    Could not deliver message to the following recipient(s):

    Failed Recipient: adam@XXXXXXXXXXXXXXXXXX.com
    Reason: Failed four attempts to connect to recipients mail server

    -- The header and top 20 lines of the message follows --

    Received: from XXXXXXXXXXXXXXXXXX [XXXXXXXXXXXXXXXXXX] by XXXXXXXXXXXXXXXXXX.com with SMTP;
    Fri, 5 Nov 2004 16:07:18 -0500
    From: "Peter"
    To: "'Adam'"
    Cc: "'Adam'" ,

    Subject: Updates
    Date: Fri, 5 Nov 2004 16:07:22 -0500
    Message-ID: <000001c4c37b$723f95e0$6501a8c0@PAPERSTREET>
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_NextPart_000_0001_01C4C351.89698DE0"
    X-Priority: 3 (Normal)
    X-MSMail-Priority: Normal
    X-Mailer: Microsoft Outlook, Build 10.0.3416
    Importance: Normal
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180

    This is a multi-part message in MIME format.

    ------=_NextPart_000_0001_01C4C351.89698DE0
    Content-Type: text/plain;
    charset="us-ascii"
    Content-Transfer-Encoding: 7bit
  2. peteboyd

    peteboyd New Member

    Any help would be appreciated as this is still continuing. Thanks.
  3. gothamweb

    gothamweb New Member

    Have you looked at your DNS?

    If you are managing DNS for this user, and your DNS points mail to your server (and assuming that your mail server is looking up the zone in your dns), then it will attempt to deliver it locally.

    So from your mail server try pinging their mail server and see where it takes you. If it takes it back to you then DNS is the problem.

    Sal
  4. peteboyd

    peteboyd New Member

    Thanks, but it pings their mail server and not our mail servers IP address. I have tried it from my desktop and from the server and I get the same remote IP address of their email server. Any other ideas? Does their system simply suck and it not accepting our email?
  5. gothamweb

    gothamweb New Member

    I'm not that familiar with SM yet but have you looked at the logs?

    If it is not a DNS issue, then maybe somehow there is still some entry in SM where SM see's the domain as local.
  6. peteboyd

    peteboyd New Member

    That is what I was trying to get help with. Where are the log files that would show this in SmarterMail.
  7. gothamweb

    gothamweb New Member

    Depends on your install, go to Settings -> Log Settings and it should show you where SM stores logs.

    Also have you looked if the domain is in domainlist.xml?
  8. peteboyd

    peteboyd New Member

    Checked the domains.xml file and it had no reference. I have upgraded all of the log files to details view so hopefully I can see where the error is occuring. Thanks.
  9. ST-BGrosz

    ST-BGrosz SmarterTools Staff

    Hi Pete,

    Since it says "Failed ... to connect .." that means it doesn't see the domain as a local domain. It is trying to find the destination mail server to send to and send the message there but it is failing to do that.

    The delivery log is the one that we are interested in. Can you set that to "Detailed Debug" on the "Settings->Log Settings" page? Then send a message to that domain and wait 15 minutes or so to make sure it has tried to send once or twice and then send me todays delivery log from the "c:\SmarterMail\Logs" directory. Please include the destination email address that you tried to send to so I know what to look for.

    You can send that to support@smartertools.com (Attention: Bryon).

    Thanks.