connection actively refused 127.0.0.1:17001

Discussion in 'SmarterMail' started by RichardF, Oct 12, 2009.

  1. RichardF

    RichardF Member

    I get the log in screen and after trying to log in i get this

    No connection could be made because the target machine actively refused it 127.0.0.1:17001
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it 127.0.0.1:17001

    Source Error:

    [TABLE]
    Code:
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
    [/TABLE]

    Stack Trace:

    [TABLE]
    Code:
    [SocketException (0x274d): No connection could be made because the target machine actively refused it 127.0.0.1:17001]   System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) +10259418   System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) +539   SmarterTools.SmarterMail.Remoting.IMail.GetGlobalMailSettings(String sessionStr) +0   SmarterTools.SmarterMail.Remoting.RemoteMail.GetGlobalMailSettings(String sessionStr) +91   SMWeb.HelperClasses.RemoteWrapper.GetGlobalMailSettings(UserData usr) +39   SMWeb.Login.DoLoginInternal(String username, String password, Boolean rememberMe) +758   SMWeb.Login.DoLogin(String username, String password, Boolean rememberMe) +16   System.Web.UI.WebControls.ImageButton.OnClick(ImageClickEventArgs e) +90   System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) +164   System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +32   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3087
     
    
    [/TABLE]

    <!--><!-->it all worked well for a month..

    restarted services and server

    switched from iis as webserver to the smartermail webserver on port 9998, but both show this

    what is causing this?

    ------------------------------​
    Version Information: Microsoft .NET Framework Version:2.0.50727.4016; ASP.NET Version:2.0.50727.4016

    This is what I find in the eventvwr

    System.NullReferenceException: Object reference not set to an instance of an object.

    at SmarterTools.SmarterMail.Mime.RFC2822HeaderField..ctor(String name, String valueStr)

    at SmarterTools.SmarterMail.Mime.RFC2822Header.SetField(String fieldName, String newValue)

    at SmarterTools.SmarterMail.RelayServer.RemoteDeliverySession.PerformSmartHostActions(RemoteRecipient remoteRecipient, List`1 blockList, Boolean&amp; customSend)

    at SmarterTools.SmarterMail.RelayServer.RemoteDeliverySession.Send()

    at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)

    at System.Threading.ThreadHelper.ThreadStart()
  2. RichardF

    RichardF Member

    The problem occured after enabling commtouch spam scanning
  3. jiriarte

    jiriarte New Member

    Richard,

    Were you able to solve the problem?

    I am getting the same error message in my system.

    Regards,

    Jorge Iriarte
  4. RichardF

    RichardF Member

    Yes.

    First with Shadow Copy I restored settings from before I was changing spam filters, then I restarted the services and IIS and all was up and running.

    SM support told me the problem was with configured incoming gateways. They have the option what to do with spam. In SM version before 6.5 you should not select &lsquo;No Action&rsquo; but allways select a funtion what to do with spam. So I selected to put something in the header for the low and medium spam settings.

    SM 6.5 shouldn't have this bug anymore
  5. NaveedZ

    NaveedZ New Member

    i am migfht be too late, but i was having same issue and when i saw :)))) "Mail Service was on mannual startup and when server got rebooted, service didint startup so error came"

    connection actively refused 127.0.0.1:17001