1. This forum is read-only and considered to be an Archive. Please utilize the SmarterTools Community for future interaction and posts.

ClamAV: No connection could be made because the target machine actively refused it

Discussion in 'SmarterMail' started by EricBourland, Mar 19, 2012.

  1. EricBourland

    EricBourland Member

    version: SmarterMail 9.1.

    Hi. My delivery log reports many of these notices from ClamAV:


    11:55:25 [01135] Unable to run Clam virus checks: System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 127.0.0.1:3310
    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
    at SmarterTools.SmarterMail.MailStore.Spam1.ClamDClient.CheckScan()


    Does this mean that incoming emails are not being scanned by ClamAV? Thanks for any advice.

    Eric Bourland
  2. RichardF

    RichardF Member

    i have the same.
    can't find why
    01:59:19 [91057] Unable to run Clam virus checks: System.Net.Sockets.SocketException (0x80004005): No connection could be made because the target machine actively refused it 127.0.0.1:3310
    at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
    at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
  3. EricBourland

    EricBourland Member

    >>>No connection could be made because the target machine actively refused it 127.0.0.1:3310

    I would guess that the target machine is, in fact, localhost? So my own SmarterMail server is refusing to connect with ClamAV?
  4. juliandormon

    juliandormon New Member

    Did you get this resolved? I am having the same issue.

    Did you get this resolved? I am having the same issue. Much appreciated!
  5. Ameetm

    Ameetm New Member

  6. timr

    timr Member

    When i try to run clamd from the command line i get :
    "The program can't start because MSVCRT100.dll is missing from your computer. Try reinstalling the program to fix this problem"

    I updated to smartermail 11.x last night, it did not prompt me to reboot so I didn't. Is it possible the server needs a reboot for the dll to register?
  7. timr

    timr Member

  8. timr

    timr Member

    from clamd.log

    Tue Mar 05 15:33:01 2013 -> clamd daemon 0.97.6 (OS: win32, ARCH: i386, CPU: i386)
    Tue Mar 05 15:33:01 2013 -> Log file size limited to 1048576 bytes.
    Tue Mar 05 15:33:01 2013 -> Reading databases from C:\PROGRA~2\SMARTE~1\SMARTE~1\Service\Clam\share\clamav
    Tue Mar 05 15:33:01 2013 -> Not loading PUA signatures.
    Tue Mar 05 15:33:01 2013 -> Bytecode: Security mode set to "TrustSigned".
    Tue Mar 05 15:33:01 2013 -> ERROR: Can't open file or directory
  9. chicagonettech

    chicagonettech Product Expert

    When you updated did you UNINSTALL the OLD version, REBOOT to unlock any locked files, BACKUP your prior data files, install the new version and then reboot?

    Even though it does not prompt you to reboot, it is always a good idea with any Windows operating system.

    Regarding the uninstall, that is clearly stated in the SmarterMail major version upgrade instructions and has been discussed on here in several other threads.

    If you did NOT uninstall the old version, then you will need to UNINSTALL the most recent update, REBOOT, re-install the most recent version and reboot again - just to make certain no files are locked.
  10. timr

    timr Member

    Yes, I BACKED up first. I actually made a full DISK IMAGE just in case, in addition to FILE LEVEL backups.

    I assumed that the WINDOWS INSTALLER would take care of locked files, uninstalling old versions, and prompting for a reboot if needed. Thats kind of its purpose :)

    Anyways, thanks for the feedback - I'll give it a shot.
  11. timr

    timr Member

    Installing the Visual C++ 2010 Redistributable and restarting the server fixed the issue.
  12. EricBourland

    EricBourland Member

    Here is the intelligence I have received regarding this issue. I worked with my ISP, Viviotech.net. They were proactive and knowledgeable. They installed the Visual C++ 2010 Redistributable; we also uninstalled and reinstalled Smartermail -- which was tedious -- but these actions seemed to have solved the problem.

    I am going to wait a while before updating to SmarterMail 11 -- but I look forward to seeing if ClamAV management improves.

    HTH.

    Eric
  13. mgraveen

    mgraveen Member

    I'm running SM11.x on Windows Server 2012 with the same issue. Installing the Visual C++ 2010 Redistributable (x86 version) http://www.microsoft.com/en-us/download/details.aspx?id=5555 worked for me. If you install the Visual C++ 2012 Redistributable x64 not only will it not work but you'll get that runaway Updating ClamAV database in the delivery logs
    19:20:08 Updating ClamAV database...
    19:20:08 Updating the ClamAV database has completed successfully
    19:20:11 Updating ClamAV database...
    19:20:11 Updating the ClamAV database has completed successfully
    19:20:14 Updating ClamAV database...
    19:20:14 Updating the ClamAV database has completed successfully

    My process:
    Uninstall SmarterMail
    Reboot
    Install Visual C++ 2010 Redistributable (x86 version)
    Reboot (just in case)
    Install SmarterMail
    Reboot

    Hope this helps,

    Mike
  14. EricBourland

    EricBourland Member

    Mike, good to know. I am going to install SmarterMail 11 later this month and this procedure, while it does make me jump through some hoops, is probably the procedure I will follow.

    Eric
  15. ST-BGrosz

    ST-BGrosz SmarterTools Staff

    We updated our SmarterMail 10 and 11 installers to check for the x86 vs 2010 c++ redistributable and install it if it doesn't exist.
  16. timr

    timr Member

    Awesome, thansk Bryon!!
  17. David Pierson

    David Pierson Member

    Hmmm. I downloaded SM 11 Enterprise just one day ago (at Sat, 09 Mar 2013 06:17:24 -0800 (PST) according to the timestamp from my download email) and installed it, and I had the missing MSVCRT100.dll problem. This was a brand new install on a new Win 7 box.
  18. chicagonettech

    chicagonettech Product Expert

    Byron was indicating this will be included in the next minor release and forgot to include that information in his post. That information was included in other posts by SmarterMail staff members. It was probably an oversight on his part.

    The next interim release is tentatively scheduled for this Thursday evening.
  19. ST-BGrosz

    ST-BGrosz SmarterTools Staff

    Sorry for the confusion. ChicagoNetTech is right that I meant this would be in the next minor releases of SmarterMail 10 and 11.

    We will be releasing those updates this Thursday.
  20. David Pierson

    David Pierson Member

    I'm trying to install the new 11.0.4821 minor upgrade to my 11.0 system. The wizard listed the Microsoft Visual C++ 2010 Redistributable Package (x86) as a requirement, downloaded it (4MB), and said Installing Microsoft Visual C++ 2010 Redistributable Package (x86) on the main wizard page. A popup box appeared saying "The installation of Microsoft Visual C++ 2010 Redistributable Package (x86) appears to have failed. Do you want to continue the installation?".

    I've said No, in case there is something you'd like me to go look at, and as I'm not urgent on the upgrade, I've left it for now.

    I did stop IIS prior to starting the install - I've set it up to use IIS instead of the built in webserver, and have not noticed any other gremlins.

    Win 7 64 bit, brand new install of 11.0 (so no "baggage").