Question Binding - IP Addresses

Discussion in 'SmarterMail' started by giovenetwork, Oct 22, 2011.

  1. giovenetwork

    giovenetwork New Member

    In this section of SmarterMail 8 I have 2 IP: the first is correct with 4 ports enabled, and a second (different) with no port enabled and the message "The selected IP address was not found on this server." The IP is 192.168.1.121 .
    How can I remove this IP ?
    There is no deletete button.

    Thanks

    Giorgio
  2. chicagonettech

    chicagonettech Product Expert

    Check under the SmarterMail ADMIN login, under SETTINGS, BINDINGS, IP addresses to see if you have bound that IP address to a host name used by SmarterMail.

    If you have, and do not have a legitimate use for the host name or IP ADDRESS, then REMOVE IT by right clicking and DELETING it Make certain there is no valid reason for this IP address to be in use before removing it.

    Once you do that, you should see only the IP ADDRESS or ADDRESSES you have bound to host names for SmarterMail. In many cases, there will be only one. Some hosting providers have multiple IP addresses and host names in this screen.
  3. giovenetwork

    giovenetwork New Member

    Thank You chicagonettech, with right clicking on the wrong IP I have only "Modify", not "Delete" :( .
    I'm using SmarterMail free v8.3.4296.

    Giorgio
  4. chicagonettech

    chicagonettech Product Expert

    Try SETTINGS, HOSTNAMES and see if SmarterMail allowed you to setup an IP address without a host name associated with the address?

    If so, then DELETE the 192.168.1.121 IP address from there, but ONLY if it is not associated with a host name. If you are not the only ADMIN level administrator for SmarterMail, someone else may have set this up for something and never completed, or still be in the process of, the setup.
  5. seph

    seph New Member

    I'm having the same problem. I have followed steps as described above and have also edited the mailconfig.xml file & restarted... old IP is still there.
  6. dsf123

    dsf123 Member

    Hi,

    I had this issue too, found out the old ip address was in the Registry, you need to remove the old ip from there too, than restart MailService.

    Here are the keys I found the old ip address in :

    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\{INTERFACE}
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Tcpip\Parameters\Interfaces\{INTERFACE}
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\{INTERFACE}
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Tcpip\Parameters\Interfaces\{INTERFACE}

    -dave
  7. chicagonettech

    chicagonettech Product Expert

    Did you check all of the NIC interfaces on your server? Did you go into ADVANCED settings on each card to see if the IP address was listed in there. Removing IP addresses via the registry is not something I would do unless it was an absolute emergency.

    What version of SmarterMail are you running, Dave?

    You may already be aware of this but the changes made to how ports are mapped to IP addresses, beginning with SmarterMail 8, trips quite a few people up:

    If you are running 7 or 8, the IP Address / PORT Bindings were moved and must be updated in:

    SETTINGS ==> BINDINGS ==> IP ADDRESSES

    The ports must be bound in SETTINGS ==> BINDINGS ==> PORTS, but the IP ADDRESS must exist for a port to be bound to it.

    This can become more confusing when you run multiple IP Addresses, as we do. We have one for our NON-SSL interface and another for our SSL interface. We did this to support TLS on a per customer basis.
  8. dsf123

    dsf123 Member

    Hi Bruce,

    Here is some clarification in my situation, I am running both SmarterMail 8 and 9 free version, in a vmware esxi setup. I cloned the OS, so that is why the old nic stuff is only in the registry.

    I also seen this when you get a new NIC card, the old one disappears, and only found in registry, so when you input the new ip, it says it is already in use, but I only can find it in registry, maybe there is a better way?

    It is very cool starting in v8 of SmarterMail you don't even have to add a domain to get it to answer to smtp :) I believe that is the purpose of Binding, along with making it simpler to configure, once you understand how to set it up.

    -dave
  9. c1tech

    c1tech New Member

    Same issue, ver Enterprise 9.2.4464, old IP not on server NIC, not in SM Hostnames, no bindings, not attached to any SM Domains, restarted server, but no way to remove old IP.
    Anyone know how to remove old unused IP Addresses?
  10. dsf123

    dsf123 Member

    Hi c1tech,

    Did you go through the registry using regedit and search for the ip address, I gave the location of the registry entries in a prior post above..

    -dave
  11. c1tech

    c1tech New Member

    Thanks Dave but I prefer to find the proper way to remove, I might open a support ticket as it might even be a bug.
  12. Wheemer

    Wheemer Senior Member

    If there is an IP in those registry locations then it's not Smartermails fault. So I don't see how it could be a bug.

    Sounds like the proper solution was already pointed out.